MegaProxy Rotating service issue
Incident Report for ProxyRack
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 01:40 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results
Posted Apr 17, 2020 - 01:10 GMT+08:00
Investigating
We are currently investigating the issue
Posted Apr 17, 2020 - 00:27 GMT+08:00
This incident affected: Unmetered Residential.