MegaProxy Rotating service issue

Incident Report for Proxyrack

Postmortem

The issues over the past 48 hours were all related to our datacenter and unfortunately out of our control.

This was their response:

Ok we were able to track down the events, yesterday there was a power issue in the datacenter and this morning one of our fibers went down. We have turned on a new port with a new carrier inside that DC to avoid this ever happening again.

We will be looking at new options for redundancy to prevent this in the future.

Posted May 15, 2026 - 09:56 GMT+08:00

Resolved

Datacenter has reported that the issues are resolved and they will continue monitoring.
Posted May 15, 2026 - 08:33 GMT+08:00

Monitoring

Performance is looking more stable
Posted May 14, 2026 - 23:53 GMT+08:00

Investigating

We are currently investigating the issue
Posted May 14, 2026 - 22:52 GMT+08:00
This incident affected: Unmetered Residential.