Premium Residential Proxies service issue

Incident Report for Proxyrack

Resolved

This incident has been resolved. Was a once off hiccup with the DNS.
Posted May 22, 2026 - 20:30 GMT+08:00

Monitoring

Performance is looking more stable
Posted May 22, 2026 - 18:00 GMT+08:00

Investigating

We are currently investigating the issue
Posted May 22, 2026 - 16:54 GMT+08:00
This incident affected: Premium Residential.