The issues over the past 48 hours were all related to our datacenter and unfortunately out of our control.
This was their response:
Ok we were able to track down the events, yesterday there was a power issue in the datacenter and this morning one of our fibers went down. We have turned on a new port with a new carrier inside that DC to avoid this ever happening again.
We will be looking at new options for redundancy to prevent this in the future.
Posted May 15, 2026 - 09:57 GMT+08:00
Resolved
Working as expected now.
Posted May 14, 2026 - 13:17 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 14, 2026 - 12:20 GMT+08:00
Investigating
There appears to be an ongoing power / network issue with the datacenter we use - http://rackdog.com/
They are aware of this and are trying to fix it asap.
We do apologise for this irregular downtime.
Posted May 14, 2026 - 11:23 GMT+08:00
This incident affected: Unmetered Residential, USA Rotating, Global Rotating, Premium Residential, Private Residential, and Static USA Proxies.