MegaProxy Rotating service issue

Incident Report for Proxyrack

Resolved

This incident has been resolved.
Posted May 26, 2026 - 15:56 GMT+08:00

Monitoring

Performance is looking more stable
Posted May 26, 2026 - 14:54 GMT+08:00

Investigating

We are currently investigating the issue
Posted May 26, 2026 - 13:47 GMT+08:00
This incident affected: Unmetered Residential.