Megaproxy exit node downtime
Incident Report for ProxyRack
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 23:17 GMT+08:00
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2020 - 14:03 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results
Posted Mar 12, 2020 - 14:02 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 14:01 GMT+08:00
This incident affected: Unmetered Residential.