Connection issues with Premium Residential proxies
Incident Report for Proxyrack
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 23:11 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2024 - 22:30 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Nov 19, 2024 - 21:55 GMT+08:00
This incident affected: Premium Residential.