MegaProxy Rotating service issue
Incident Report for ProxyRack
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 01:53 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results
Posted Apr 08, 2020 - 01:22 GMT+08:00
Update
Our datacenter has identified a PSU failure in our main load balancer and is working on replacing it
Posted Apr 08, 2020 - 01:11 GMT+08:00
Investigating
We are currently investigating the issue
Posted Apr 08, 2020 - 00:34 GMT+08:00
This incident affected: Unmetered Residential.