Mixed Datacenter Proxies service issue
Incident Report for ProxyRack
Resolved
This incident has been resolved.
Posted Apr 05, 2020 - 03:53 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results
Posted Apr 05, 2020 - 03:22 GMT+08:00
Investigating
We are currently investigating the issue
Posted Apr 05, 2020 - 03:18 GMT+08:00
This incident affected: Mixed Datacenter Proxies.